
Vroidのアバターを
Unityで動かす



３Ｄモデルにアニメーションを付ける

３Ｄモデル

風景

モーション

VRM

モデル

Unity
VRoid

Unity Assets

Unity Assets



Vroidでアバターを作る



サンプルモデルを選択
アバターを作成する
Vroid
https://hub.vroid.com/

モデルの修正をする場合は下記を参照しましょう（公式）
https://vroid.pixiv.help/hc/ja/articles/4405597663385

https://hub.vroid.com/
https://vroid.pixiv.help/hc/ja/articles/4405597663385


VRMエクスポート

VRMエクスポート

ＶＲＭにエクスポートを開始します



フォーマットの設定

Clusterの場合
①ポリゴンの数が32,000以下であること
②マテリアル数が８であること
③ボーンの数が１２８以下であること
③テクスチャアトラスを2048×2048

利用するシステムで制限がある場合がありますので設定を変更します。



エクスポートデータ修正
再配布・改変に関する許諾範囲やアバターの人格に関する許諾範囲を
それぞれのシステムに合わせて情報を修正しましょう

フォーマット：VRM 0.0
アバター情報

タイトル
作者
連絡先
参照
バージョン

アバターの人格に関する承諾の設定

再配布・改変に関する承諾
ライセンスタイプ



Uniy Assetsの入手
VRoid → Unity → Animation 



Unityを起動します
Unity プロジェクトを作成します。
VRoidやBlenderで作成した人型３Ｄモデルを取り込む為にUnityに、UniVRMをインストー
ルします。
３Ｄモデルが移動する為のステージを作成します。

プロジェクト名
保存場所

Unity HUB

新規プロジェクト

新規プロジェクト



UnityとUnity AssetsのID登録
モデルは、BlenderやUnityで作成しますが、Unity Assets（アセット）を利用する事ができます
Unityと同じユーザーIDを利用する事で、Unityと連動して使用する事ができます

同じユーザーID

サインイン

My Assetsに登録

Assetsを利用

Assetsを入手

Unity HUB



Assets
RPG用パック
Simple Low Poly Nature Pack
https://assetstore.unity.com/packages/3d/environments/landscapes/simple-low-poly-nature-pack-157552

Unity のスターターキット
一人称
Starter Assets - First Person Character Controller | URP
https://assetstore.unity.com/packages/essentials/starter-assets-first-person-character-controller-urp-196525
三人称
Starter Assets - Third Person Character Controller
https://assetstore.unity.com/packages/essentials/starter-assets-third-person-character-controller-196526

モーションキット
Dance Animations FREE
https://assetstore.unity.com/packages/3d/animations/dance-animations-free-161313
Basic Motions FREE
https://assetstore.unity.com/packages/3d/animations/basic-motions-free-154271

地面用テクスチャ
Terrain Textures Pack Free
https://assetstore.unity.com/account/assets
Outdoor Ground Textures
https://assetstore.unity.com/packages/2d/textures-materials/floors/outdoor-ground-textures-12555 

制服ユニティちゃん
https://unity-chan.com/download/releaseNote.php?id=TPK-Hmnd-Kohaku_B

https://assetstore.unity.com/packages/3d/environments/landscapes/simple-low-poly-nature-pack-157552
https://assetstore.unity.com/packages/essentials/starter-assets-first-person-character-controller-urp-196525
https://assetstore.unity.com/packages/essentials/starter-assets-third-person-character-controller-196526
https://assetstore.unity.com/packages/3d/animations/dance-animations-free-161313
https://assetstore.unity.com/packages/3d/animations/basic-motions-free-154271
https://assetstore.unity.com/account/assets
https://assetstore.unity.com/packages/2d/textures-materials/floors/outdoor-ground-textures-12555
https://unity-chan.com/download/releaseNote.php?id=TPK-Hmnd-Kohaku_B


Simple Low Poly Nature Packを使う
https://assetstore.unity.com/packages/3d/environments/landscapes/simple-low-poly-nature-pack-157552

https://assetstore.unity.com/packages/3d/environments/landscapes/simple-low-poly-nature-pack-157552


Simple Low Poly Nature Pack
https://assetstore.unity.com/packages/3d/environments/landscapes/simple-low-poly-nature-pack-157552

Download

ImportImport

Package Manager

https://assetstore.unity.com/packages/3d/environments/landscapes/simple-low-poly-nature-pack-157552


Basic Motions FREEを使う
Basic Motions FREE
https://assetstore.unity.com/packages/3d/animations/basic-motions-free-154271

https://assetstore.unity.com/packages/3d/animations/basic-motions-free-154271


Animation Assets

Dance Animations FREE
https://assetstore.unity.com/packages/3d/animations/dance-animations-free-161313
Basic Motions FREE
https://assetstore.unity.com/packages/3d/animations/basic-motions-free-154271

Unity Assetsからモーションのアセットをダウンロードして３Ｄモデルに割り当て動かします。

https://www.youtube.com/watch?v=02yENu82rIU
Unity Assets

Package Manager Import

Import

https://assetstore.unity.com/packages/3d/animations/dance-animations-free-161313
https://assetstore.unity.com/packages/3d/animations/basic-motions-free-154271
https://www.youtube.com/watch?v=02yENu82rIU


Unityでシーンを作る



シーンを取り込む



UniVRMインポート



UniVRM ダウンロード
Unity for VRMダウンロード
https://github.com/vrm-c/UniVRM/releases

VRM 0.x Import/Export がVRoid対応になります。

https://github.com/vrm-c/UniVRM/releases


UniVRMインポート

インポート

ダウンロード インポート



アバターをインポート



３Ｄモデルをインポート

VRoid

VRM出力

ＶＲＭフォーマットのファイルをAssetsの中にドラック＆ドロップするとインポートされます。
インポートされると、アニメーション等が付随したPrefubが作成されます。
作成された、PrefubをHierarchyにドラック＆ドロップします



MoveControllerの追加



概要
MoveControllerを作成して、アバターの操作を行います。
WSADキーやアローキーでアバターの移動を行います。

MoveController

1)Assets にScriptsフォルダーを作成
2)3DObject→Create→C# Scriptでスクリプトを作成
3)名前を”CameraScript”とします
4)CameScript を Hierarchy内の MainCamera へドラッグ＆ドロップします
5)スクリプトのターゲットを【モデル名]にします



MoveController
using System.Collections;
using System.Collections.Generic;
using UnityEngine;

public class MoveController : MonoBehaviour {

private Animator animator;
// Start is called before the first frame update
void Start() {
animator = GetComponent<Animator>();
}
// Update is called once per frame
void Update() {

if (Input.GetKey(KeyCode.UpArrow) || Input.GetKey(KeyCode.W)) {
animator.SetBool("Walk", true);
transform.position += transform.forward * 0.01f;

} else {
animator.SetBool("Walk", false);
}
if (Input.GetKey(KeyCode.DownArrow) || Input.GetKey(KeyCode.S)) {

animator.SetBool("Back", true);
transform.position -= transform.forward * 0.01f;

} else {
animator.SetBool("Back", false);

}
if (Input.GetKey(KeyCode.RightArrow) || Input.GetKey(KeyCode.D)) {

transform.Rotate(0.0f, 1.0f, 0.0f);
}
if (Input.GetKey(KeyCode.LeftArrow) || Input.GetKey(KeyCode.A)) {

transform.Rotate(0.0f, -1.0f, 0.0f);
}

}
}



Scriptをアタッチ



カメラ追従



1)Assets にScriptsフォルダーを作成
2)3DObject→Create→C# Scriptでスクリプトを作成
3)名前を”CameraScript”とします
4)CameScript を Hierarchy内の MainCamera へドラッグ＆ドロップします
5)スクリプトのターゲットを【モデル名]にします

アバター へカメラの追従



Targetをモデルにする
1）カメラ移動用のScript 「CameraScript.cs」を作成
2)Cameraにスクリプトをアタッチ
3)ターゲットをアバターに指定



アバター へカメラの追従
using System.Collections;
using System.Collections.Generic;
using UnityEngine;

public class CameraScript : MonoBehaviour
{

public GameObject target;
private Vector3 distance;

// Start is called before the first frame update
void Start()

    {
distance = transform.position - target.transform.position;

    }

// Update is called once per frame
void Update()

    {
transform.position = target.transform.position + distance;

    }
}



モーション追加



Animatorを選択する

Animator

① Hierarchy からアバターを選択
② Animator の Controller の  “◎”をクリック
③ ウィンドウが開く それぞれのアニメーターをダブルクリック

Controller

モデル選択



モーションの切り替え



Animetor Contolerの作成

State
モーションを入れます

Transition
切り替えのつながりを指します

Parameter
切り替えのタイミングのパラメータ

motion controller 

Walk

BackWalk

Waitk

Object Winodw > Create > Animetor Contoler



床との緩衝



アバターにRigidbody と Capsule Collider の値を下図のように設定する

・Freeze Rotation
X,Y,Z それぞれチェックを入れる

床との干渉

・Center
X=0,Y=0.85,X=0

・Height
1.75

Rigidbody：物理法則を与える
Capsule Collider：カプセル型の干渉の形状



完成



参考資料



Unity 基礎



新規プロジェクト

プロジェクト名

保存先



初期画面

Hierarchy 
ヒエラルキー

Project
プロジェクト

Hierarchy（ヒエラルキー）：シーンに使うパーツを入れる場所
Project（プロジェクト）：プロジェクト全体の必要なパーツを入れておく場所
Inspector（インスペクター）：オブジェクトの属性を表示します。

・Projectは、ファイルのリスト
・ダウンロードした素材や、作成した
C#スクリプトなどはproject内に保存される

Inspector
インスペクター

Scenes
シーン



シーン

・Main Cameraは
ゲーム画面を映し出すカメラ

・Directional Lightは
ゲーム内を照らす明かり

Directional Light
ライト

Camera
カメラ



画面操作
マウス 左 ： オブジェクト選択
マウス 右 ： 視点移動
マウス 中 ： 画面移動
マウス ホイール：拡大・縮小

視点方向



オブジェクトを置いてみる
ゲームオブジェクトを作成します。
Game Object → 3D Object → Cube

作成されたCuleをクリックします。
Inspector（インスペクター）：3D Object のパラメータ

3D Object
キューブ(Cube)



シーンとカメラ
Scene
シーン

Game
ゲーム

Camera
カメラ

Directional Light
ライト

ゲーム実行ボタン

 

一時停止ボタン

 



オブジェクト編集
作成したCuleをクリックします。
Inspector（インスペクター）の3D Object のパラメータを変更する事で変更できます。

移動
回転
拡大



地面を作る

Game Object → 3D Object → Terrain

X: -500
Y: 0
Z: -500



オブジェクトを配置する

Cube
X: 0
Y: 10
Z: 0



実行してみる

ゲーム実行ボタン

 

一時停止ボタン

 



重力

Add component → 重力（Sphere)→ Regidbody



色を付ける

１）Materialを保存するフォルダを作ります。
Projectタブの「Assets」フォルダを右クリックし、[Create] → [Folder]をクリックします。

２）Materialsフォルダの中に、新しくMaterialを作成する。
Materialsフォルダをダブルクリックして開きます。
Materialsフォルダの中で右クリック → [Create] → [Material] をクリックします。

３）InspectorのMain Mapsの色を青にします。
４）Materialの名前を変更します。

例：Material_Bule
４）青色のマテリアルをObjctに反映します。

Hierarchy上のCubeを選択してInspectorを開きます。
Blue_Materialをドラッグ＆ドロップでAdd Component下の空間へ放り込みます。

マテリアル（Material）



色を付ける



VRMについて



概要
UnityやBlenderで修正ができる３Ｄモデルを作成します。
アプリ毎に読み取れるファイル形式があります。
人型モデルは「ＶＲＭ形式」を使用します。
参考：３Ｄフォーマット（一部）

VroidのサンプルアバターをVRMで出力します。

Model.vrm

エクスポート インポート



VRMについて
「VRM」はVRアプリケーション向けの人型3Dアバター（3Dモデル）データを扱うためのファイルフォーマットです。 
glTF2.0をベースとしており、誰でも自由に利用することができます。

VRMは複数アプリケーション間で相互利用されることが想定される、VR時代の3Dアバターフォーマットです。たとえば
「ネットワークに相互接続されたアバターによるVRコミュニケーション」を考えた場合、 自分のアバターデータを「他の
人から自分の姿が見えるように」他のユーザへ送信する 、ということも行われることになります。
この場合、従来の考え方に基づく「再配布」規定だけでは対応できない場面が考えられます。そのため、VRMではモデル
データ自体に対しての改変・再配布規定（Creative Commonsなどから設定可能）のほかにモデルデータを使用して「人格
を演じる」ことについての許諾規定を ファイルに設定できる など、VR時代を想定したフォーマットとなっています。

VRMは、Unity、VRChat、Cluster等に利用する事ができます。



アバターの人格に関する許諾範囲(Personation / Characterization Permission)

アバターの人格に関する許諾範囲(Personation / Characterization Permission)
アバターに人格を与えることの許諾範囲(A person who can perform with this avatar)
アバターを操作することはアバター作者にのみ許される(The avatar may only be manipulated by its creator)

明確に許可された人限定(Authorized only to explicitly specified person)

全員に許可(Authorized to anyone)

このアバターを用いて暴力表現を演じることの許可(Permission to perform violent acts with this avatar)
不許可(Disallow)
許可(Allow)

このアバターを用いて性的表現を演じることの許可(Permission to perform sexual acts with this avatar)
不許可(Disallow)
許可(Allow)

商用利用の許可(For commercial use)
不許可(Disallow)
許可(Allow)

その他のライセンス条件(Other License Url)
上記許諾条件以外のライセンス条件がある場合はそのライセンス文書へのURLを記述



再配布・改変に関する許諾範囲(Redistribution / Modifications License)

再配布・改変に関する許諾範囲(Redistribution / Modifications License)
ライセンスタイプ(License Type)
再配布禁止(Redistribution Prohibited)
著作権放棄(CC0)
Creative Commons CC BYライセンス(CC_BY)
Creative Commons CC BY NCライセンス(CC_BY_NC)
Creative Commons CC BY SAライセンス(CC_BY_SA)
Creative Commons CC BY NC SAライセンス(CC_BY_NC_SA)
Creative Commons CC BY NDライセンス(CC_BY_ND)
Creative Commons CC BY NC NDライセンス(CC_BY_NC_ND)
その他(Other)
その他ライセンス条件(Other License Url)
上記許諾条件以外のライセンス条件がある場合はそのライセンス文書へのURLを記述



参考：３Ｄフォーマット（一部）
ファイル形式 説明

.stl
3D System（3D システム）社によって開発されたファイル形式
3Dプリントをする上での標準形式となっており、多くのCADソフトウェアで読み込みや書き出しが
可能

.step

.stp
ISO（国際標準化機構）により開発された3DCADデータのファイル形式
国際標準として普及が進んでおり、ほとんど全てのCADソフトウェアで対応している

.obj
Wavefront（ウェーブフロント）社が開発したファイル形式
表面材質やテクスチャ情報も保持できるがアニメーション情報は保持できない
多くの3Dモデリング、レンダリングソフトが対応している

.fbx
Autodeskに買収されたAlias（エイリアス）社がオープンソースとして開発したファイル形式
カラー情報やアニメーション情報も保持できるため、3DCGの標準フォーマットとして浸透している

.wrl
Web上で使用することを前提に設計されたファイル形式
カラーやアニメーション情報に加え、wrlファイルへのリンクURLも保持できる

.vrm
「VRM」はVRアプリケーション向けの人型3Dアバター（3Dモデル）データを扱うためのファイル
フォーマットです。 glTF2.0をベースとしており、誰でも自由に利用することができます。
https://vrm.dev/#

.gbl

「glTF（GL Transmission Format）」とは、3Dモデルのファイル形式のひとつで、主にWebブラウ
ザ上で動作するコンテンツを作る際に用いられるフォーマットです。
2000年にKhronos Groupによって開発・策定されました。
また、glTFをバイナリ形式に変換したものが「GLB」です。
palan3DではglTF/GLBをPC・スマートフォン共通の3Dモデル表示画面、AndroidのAR表示用に使用し
ます。

https://vrm.dev/


エラー処理



Prefab (プレハブ)に変換されない場合

Migr To Vrm 1 レ
【Revert】

Vroid のVRMは、VRM 0.X なので VRM 0.x Import/Export をインストールする必要があります。
下記のチェックをいれると、 VRM 0.x →VRM 1.x に変換されます。



画面がピンクの時
https://qiita.com/kazuma_f/items/4d265c5615f1d441ffe9#%E8%A3%9C%E8%B6%B3

Built-in to URP

レ Rendering Strin

Initialize Convert Convert Asets

Edit > Render Pipeline > Universal Render Pipeline >Upgrade Project Materials to UniversalRP Materials

https://qiita.com/kazuma_f/items/4d265c5615f1d441ffe9#%E8%A3%9C%E8%B6%B3


Starter Assets - Third Person Character Controller





下記URLより、VRoid Studio ダウンロードします
インストールは、手順に従ってください

https://vroid.com/studio

VRoid Studio ダウンロード

https://vroid.com/studio


VRoid Studio インストール



UnityChan!ダウンロード
Unity Assets Storeからアセットをダウンロードします。
Window→PakageManager→PakageMyassets→【Unity-Chan! Model】
→Download→Import

PakageManager

Import



Unity-Chanモーションの取り込み



Uniy AssetsでUnity-Chan! Modelを入手

Unity-Chan! Model
https://assetstore.unity.com/packages/3d/characters/unity-chan-model-18705

https://assetstore.unity.com/packages/3d/characters/unity-chan-model-18705


UnityChan!ダウンロード
Unity Assets Storeからアセットをダウンロードします。
Window→PakageManager→PakageMyassets→【Unity-Chan! Model】
→Download→Import

PakageManager

Import



モーションスクリプト追加
1) Hierarchy からアバターを選択
2) アバターのInspector からAdd Component をクリック
3) ウィンドウが開く Scripts を選択
4) UnityChan
5) UnityChanControlScriptWithRigidBodyを選択



Uniy AssetsでUnity-Chan! Modelを入手

Unity-Chan! Model
https://assetstore.unity.com/packages/3d/characters/unity-chan-model-18705

https://assetstore.unity.com/packages/3d/characters/unity-chan-model-18705


① Hierarchy からアバターを選択
② Animator の Controller の  “◎”をクリック
③ ウィンドウが開く UnityChanLocomotions を  ダブルクリック

Animator追加

Animator



モーションスクリプト追加
1) Hierarchy からアバターを選択
2) アバターのInspector からAdd Component をクリック
3) ウィンドウが開く Scripts を選択
4) UnityChan
5) UnityChanControlScriptWithRigidBodyを選択



・▶（ゲーム実行）をクリック
・方向キーでアバターが動くようになりました
・動かし終えたら、もう一度 ▶を選択し、プレイモードを終了

ゲームスタート

※プレイモード中に、編集したものはリセットされる為、
必ず編集する際は、プレイモード中ではないか確認しましょう



地形のアレンジ



地面にテクスチャ（模様）を付ける
1)Unity Assets 入手

Terrain Textures Pack Free ：https://assetstore.unity.com/account/assets

2)Paint Terrain を クリック
3)Paint Texture を 選択
4)Edit Terrain Layers をクリックし、create Layer を選択
5)Select Texture2D  ウィンドウが開く ・GrassHillAlbedo をダブルクリック

Paint Texture Create Layer 

https://assetstore.unity.com/account/assets


地面に起伏を付ける
①Paint Terrain をクリック
②Raise or Lower Terrain を選択
③ブラシタイプ、サイズを適当に調整
④ Terrain 上でドラッグすると、ドラッグした部分が隆起します
※ Shiftキーを押しながらドラッグすると逆に沈みます



・Inspector から Terrain を選択
①Paint Trees を クリック
②Edit Trees をクリックし、Add Tree を選択
③”◎”をクリック
④Broadeaf_Mobile を選択
⑤ Add をクリック

地面に木を植える



・オリジナルのアバターをオリジナルのステージで動かせるようになりました！！



① Hierarchy からアバターを選択
② Animator の Controller の  “◎”をクリック
③ ウィンドウが開く UnityChanLocomotions を  ダブルクリック

Animator追加

Animator



③ モーションを付ける

① Hierarchy から
アバターを選択

② Animator の Controller の
 “◎”をクリック

③ ウィンドウが開く
 UnityChanLocomotions を

 ダブルクリック



② 移動のスクリプト（命令）を付ける

① Hierarchy から
アバターを選択

② アバターのInspectorから
    Add Component をクリック

③ ウィンドウが開く
 Scripts を選択

④ UnityChan を選択

④ UnityChanControlScriptWithRigidBodyを選択



アバターのInspector から、Rigidbody と Capsule Collider の値を下図のように設定する

・Freeze Rotation
X,Y,Z それぞれチェックを入れる

床との干渉

・Center
X=0,Y=0.85,X=0

・Height
1.75



・アバターのInspector から、Rigidbody と Capsule Collider の値
を下図のように設定する

・Freeze Rotation には
X,Y,Z それぞれ
チェックを入れる
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